jueves, 11 de noviembre de 2010

Algoritmo para convertir un Número Decimal a Binario

1.- Inicio

2.- Escribir "Introduzca un numero Decimal para la conversión"

3.- Leer Numero

4.- i=0, Binario(i)

5.- Si  Numero=0 OR Numero=1 Entonces
      Escribir "El Numero Binario es igual al Numero Decimal"
      De lo contrario
      Mientras Numero/2>1 Hacer
      Numero=Numero/2
      Numero Mod=Binario(i)
       i=i+1
      Fin Mientras

6.- Escribir "El Numero Binario es"

7.- Para i Hasta 0 Con Decremento -1 Hacer
     Escribir Binario(i)
     Fin Para

8.- Fin

5 comentarios:

  1. En qué lenguaje de programación está basado tú trabajo?

    ResponderEliminar
    Respuestas
    1. este es lenguaje de bajo nivel :D osea simplemente instrucciones en castellano jejeje

      Eliminar
    2. más bien "pseudocódigo", un lenguaje de bajo nivel es algo completamente distinto, nada que ver.

      Eliminar
  2. si quiero utilizar el Mientras en un ciclo mas sencillo como el si (condicion) entonces
    como haria?

    ResponderEliminar
  3. Muy bueno tu pseudocódigo amigo. Ayudó bastante. Saludos

    ResponderEliminar